Tool offset values corrupted when in "Inch" mode.

Help and advice for Denfords lathe control software VR Turning.

Moderators: Steve, Mr Magoo, Martin, bradders

Post Reply
MAX THE MILLER
CNC Expert
CNC Expert
Posts: 133
Joined: Tue 23 Aug , 2011 18:25 pm
Hardware/Software: Denford Triac PC. VR Milling 5.51.0.616

Tool offset values corrupted when in "Inch" mode.

Post by MAX THE MILLER » Thu 05 Jan , 2023 14:22 pm

VR TURNING VER 1.53.0.0

Open VR Turning and use the units button to select "Inch".

Connect to a real or virtual machine.

Open the tooling menu and use the ATC to change to any tool other than tool 1 which is the reference tool.

Enter some offset values for the tool. I used X = -1 and Z = -1.

Close the tooling menu and reopen it. Offset values will have been multiplied by 25.4 to give X = -25.4 and Z = -25.4.

Close the tooling menu and reopen it. Offset Values will again have been multiplied by 25.4 to give X = 645.16 and Z =-645.16.

Close the tooling menu and reopen it. Offset Values will have again been multiplied by 25.4, but 645.16 X 25.4 = 16,387.064 which is too large a number for the available fields. The values for X and Z are displayed as 9999.0000.

The problem only affects the tool in use and only occurs when units are set to "Inch". "Metric" mode is OK.

While I'm here, the tooling menu also has a field labelled "radius" (not tool nose radius). What does this value represent?

Thanks, Max.
Attachments
Tooling4.jpg
Tooling4.jpg (28.44 KiB) Viewed 84 times
Tooling3.jpg
Tooling3.jpg (27.82 KiB) Viewed 84 times
Tooling2.jpg
Tooling2.jpg (28.08 KiB) Viewed 84 times
Tooling1.jpg
Tooling1.jpg (25.13 KiB) Viewed 84 times

Post Reply