Novamill stepper driver issue

Information and questions about Denford CNC Control electronics, general electrical issues, cables, diagrams, stepper motors, drives etc...

Moderators: Steve, Mr Magoo, Martin, bradders

Post Reply
Stldrew
Posts: 1
Joined: Wed 21 Sep , 2022 11:54 am
Hardware/Software: Novamill 2006 / VR milling

Novamill stepper driver issue

Post by Stldrew » Wed 21 Sep , 2022 11:56 am

Hey guys I’m looking for some suggestions on troubleshooting my issue further.

I purchased this cnc with unknown issues. The x axis stepper was jittering so I swapped the output between the x and y. The same stepper works on the y axis so it doesn’t appear to be an issue with the motor. I don’t see any visible damage to the control board - any suggestions on what I could test with my fluke or something to narrow down the issue? Thanks!

I gambled on purchasing vr milling and afraid I might have made the wrong decision.

User avatar
Steve
CNC Guru
CNC Guru
Posts: 1397
Joined: Tue 21 Feb , 2006 16:15 pm
Location: Denford UK

Re: Novamill stepper driver issue

Post by Steve » Fri 23 Sep , 2022 9:53 am

I would try switching the drive to the motos by plgging the Y into the X and the X into the Y on the control card. You may have to remove the black key pins from the connector to do this.

viewtopic.php?f=54&t=1627.

Then by pressing the Y jog the X will move using the Y axis driver chip.

Use the secret home function and you will then be able to enter jog mode without homing up.

viewtopic.php?f=2&t=53#p104

Post Reply