Need help with Triac VMC

All info relating to the Denford Triac series of CNC milling machines

Moderators: Martin, bradders, Steve, Mr Magoo

Post Reply
Posts: 3
Joined: Tue 10 Apr , 2007 1:55 am
Location: USA

Need help with Triac VMC

Post by acephalia » Tue 10 Apr , 2007 2:08 am

Hi, I just got a triac VMC (2001) with ATC at a liquidation sale. I have some trouble operating the machine. The built-in PC powers up, and Windows loads fine. Pressing any buttons at this time on the control panel, doesn't do anything. I figured I needed to launch the control sotware. There are a few desktop icons: CNC-mill, CNC-tutor, and VR milling. I tried each one of those and no luck. I get "RS232 timeout" message that flashes once a second. I opened up the controller box, and the motion controller's LED display has "S" on it. Any suggestions, thoughts, or general help will be greatly appreciated!

UPDATE: I just tried powering it up again, and cheking the controller LED without launching the software. First the LED reads: ".L", with "." flashing, then it settles to "S" - which I suppose means "Stop". Now, I know for sure the emergency stop is NOT enagaged (i checked and rechecked, and then checked some more). I noticed that the spindle drive board's LED is not lit. Farther investigation showed however that if the white square button "ignore limit switch" is pressed the driver board does light up. My hunch is that the controller sences "E- Stop" and disables the spindle drive, among other things. Thanks again for any info you can pass on!


User avatar
Mr Magoo
CNC Guru
CNC Guru
Posts: 301
Joined: Tue 21 Feb , 2006 21:45 pm
Location: Brisbane, Australia

Post by Mr Magoo » Tue 10 Apr , 2007 11:17 am

You're right about the "S" indicating E-Stop. All the axis limit switches are wired in the E-Stop circuit in series and so one of the axis is at its extreme travel and sat on a limit switch.

Solution: Either
a) wind the axes ballscrews by hand away from the limits or
b) keep your finger on the axis limit override push button whilst you power up the software, select "machine control" mode and ask the machine to go Home.

BTW, I suggest you use the VR Milling software - You'll get more support for it here as it's better known and generally more reliable

Posts: 3
Joined: Tue 10 Apr , 2007 1:55 am
Location: USA

Post by acephalia » Tue 10 Apr , 2007 21:02 pm

Great! that worked! while pressing "axis limit override" button, I clicked the "Home All Axis" button, and sure enough the table pulled away from the closed limit switch on the Y-axis. Thanks a lot for the help!

Playing with the mill farther, I noticed that none of the pneumatic devices (ATC, guard cylinder, draw bar...) seem to work. I tried the correspondng M-codes from VR to no avail. I do have a 120 psi source connected. Also, while looking inside the main control box, I noticed that one of the wires, is dosconnected and just hanging there. The wire has "57" tag on it and it comes from the main umbellical. I can sort of guess it connects to a big relay switch near by. But, why is it disconnected and what does it control? Is there an electrical diagram anywhere available for download? Searching the support site and googling for one got me nothing. Thanks again!

User avatar
Mr Magoo
CNC Guru
CNC Guru
Posts: 301
Joined: Tue 21 Feb , 2006 21:45 pm
Location: Brisbane, Australia

Post by Mr Magoo » Tue 10 Apr , 2007 21:34 pm

When you tried the M codes in VR Milling, did the s/ware lock up, or did it just ignore the command and you could still carry on doing stuff?

Posts: 3
Joined: Tue 10 Apr , 2007 1:55 am
Location: USA

Post by acephalia » Wed 11 Apr , 2007 17:18 pm

It pretty much just ignored the commands. I could still move the table and turn the spindle on/off. While poking around I tried MintMan proggy, and there were two mint files in its directory with "triac" name. I tried both files. One of them (when MintMan downloaded the file and ran it) made the mill perform all the M-codes in rapid succession. It would open/close the guard, move/rotate ATC, do other wacky things. It was pretty scary. Still, no luck with any pneumatic M-codes from VR.

User avatar
Denford Admin
Site Admin
Posts: 3602
Joined: Fri 10 Feb , 2006 12:40 pm
Hardware/Software: Go to User Control Panel > Profile
Enter as much information about your CNC hardware and software as you can - it makes it easier for everyone to know what you're talking about then.
Location: Sunny Brighouse

Post by Denford Admin » Thu 12 Apr , 2007 9:11 am

I think you should:
  • Download the latest version of VR Milling 2

    Run Mintman again, and download Triac.mnt to the control. Once the mint is in there, it stays in flash so you won't need to run this again.
Re the mcodes, they will all work from MDI (if you have the appropriate options fitted), but you may not see them all in the MCODE button list (if they aren't enabled in parameters)....
Description=Spindle Forward

Description=Spindle Reverse

Description=Spindle Stop

Description=Coolant On

Description=Coolant Off

Description=Vice Open

Description=Vice Close

Description=Coolant on and Spindle Fwd

Description=Coolant on and Spindle Rev

Description=ATC Arm In

Description=ATC Arm Out

Description=ATC Arm Down

Description=ATC Arm Up

Description=Release Draw Bar

Description=Clamp Draw Bar

Description=Reset Carousel

Description=Carousel CW

Description=Carousel CCW

Description=Rotate Carousel Half Turn

Description=Guard open

Description=Guard Close

Description=Aux output 1 ON

Description=Aux output 1 OFF

Description=Aux output 2 ON

Description=Aux output 2 OFF

Description=Wait Aux input 1 ON

Description=Wait Aux input 1 OFF

Description=Wait Aux input 2 ON

Description=Wait Aux input 2 OFF
I'll see about the drawings, but we would normally charge administration costs for them :(

Post Reply