Problems with my rv m1 project

Help and info about Denfords CIM* and Virtual Reality CIM systems Robots and ASRS**
*(Computer Integrated Manufacturing) **(Automated Storage and Retrieval System)

Moderators: Mr Magoo, Martin, bradders, Steve

Post Reply
ali_jamal
Posts: 1
Joined: Tue 25 Dec , 2012 16:19 pm
Hardware/Software: Mitsubishi RV-M1
denford robots communication software

Problems with my rv m1 project

Post by ali_jamal » Tue 25 Dec , 2012 16:29 pm

hello everyone,

i hope someone can help me with my problems cause they are killing me.
i have a RV M1 mitsubishi robot, movemaster drive unit and am using denfords robot communication software.
1. the robot gives an error every time i would upload to it positions
2. the robot would also send an error when i upload a program evetho i would have uploaded the same program before without any problems
3. the most important problem is the following
this is an example of a program i wrote
10 MO 1
20 MO 2
30 OB +3
40 ED

NOW isnt the robot supposed to follow this program line by line, and when it finishes these movements send an output signal through bit 3, and then end the program. because in my case it doesnt, the minute i run the program and output signal is sent!!!!

User avatar
Denford Admin
Site Admin
Posts: 3586
Joined: Fri 10 Feb , 2006 12:40 pm
Hardware/Software: Go to User Control Panel > Profile
Enter as much information about your CNC hardware and software as you can - it makes it easier for everyone to know what you're talking about then.
Location: Sunny Brighouse
Contact:

Re: Problems with my rv m1 project

Post by Denford Admin » Wed 02 Jan , 2013 11:19 am

If this was all working OK in the past, my guess is that communication to the robot is getting corrupted.
Has anything changed ? Can you try another RS232 cable ?
Have you got the RVM1 manual ?
I was able to download it from here:
https://my.mitsubishi-automation.com/do ... =2&sstr=RV
The service manual may help with finding the fault.

User avatar
bradders
CNC Guru
CNC Guru
Posts: 1247
Joined: Mon 13 Feb , 2006 12:35 pm
Location: Brighouse, England
Contact:

Re: Problems with my rv m1 project

Post by bradders » Mon 07 Jan , 2013 9:58 am

Does this help for setting up DIP swithches on the RV-M1.

DENFORD TYPICAL DIP SWITCH SETTINGS FOR RV-M1 ROBOTS
Ensure that the rear silver toggle switch in the Robot control box (PC Control) is DOWN

SW1
BIT No
1. The terminator for Data transmission from the drive unit through the RS232 interface
Upper position CR+LF
Lower position CR

2. Selects whether to check if the contents of the RAM data are retained upon power up
Upper position Check is performed
Lower position Check is not performed

3. Selects the type of I/O card used
Upper position Type A16 or B16
Lower position Type A8 or B8

4. Selects whether or not to set, change, or delete the reference position data in the Cartesian co-ordinate system
Upper position Enable
Lower position Disable

5. Selects whether to enable either the drive unit front control switches or external signals for running the program while type A16 or B16 I/O card is being used
Upper position External signals
Lower position Front control switches

6. Selects whether to enable the ENT key on the teaching box to release Robot brakes
Upper position Disable
Lower position Enable

7. Not used

8. Selects whether to turn ON or OFF the buzzer
Upper position Buzzer On
Lower position Buzzer Off

SW2

Bit No Null 1 bit 1-1/2 bits 2 bits
8 0 0 1 1
7 0 1 0 1
Even Parity Odd Parity
6 1 0
Parity Enable Parity Disable
5 1 0
5 bits 6 bits 7 bits 8 bits
4 0 0 1 1
3 0 1 0 1
Baud Rate
Null X1 X16 X64
2 0 0 1 1
1 0 1 0 1


RV-M1

SW3

Bit No Baud Rate Factor
X1 X16 X64
1 1200 75
2 2400 150
3 4800 300 75
4 9600 600 150
5 1200 300
6 2400 600
7 4800 1200
8 9600 2400


Dipswitch settings


SW1
1 Off
2 On
3 On
4 Off
5 Off
6 Off
7 Off
8 On

SW2
1 Off
2 On
3 Off
4 On
5 On
6 On
7 On
8 Off

SW3
1 Off
2 Off
3 Off
4 Off
5 Off
6 Off
7 On
8 Off

Post Reply