Tool change in CNC program does not stop the spindle

Help and support using the 3D and Bitmap Machining CAM packages:
QuickCAM 3D, QuickCAM 3D Pro, QuickCAM 4D (rotary axis CAM)

Moderators: Mr Magoo, Martin, bradders, Steve

Post Reply
User avatar
Denford Admin
Site Admin
Posts: 3587
Joined: Fri 10 Feb , 2006 12:40 pm
Hardware/Software: Go to User Control Panel > Profile
Enter as much information about your CNC hardware and software as you can - it makes it easier for everyone to know what you're talking about then.
Location: Sunny Brighouse
Contact:

Tool change in CNC program does not stop the spindle

Post by Denford Admin » Mon 13 Feb , 2006 15:07 pm

When using more than one tool from QuickCAM 3D I find that the spindle does not stop when asking for the 2nd tool.

User avatar
Denford Admin
Site Admin
Posts: 3587
Joined: Fri 10 Feb , 2006 12:40 pm
Hardware/Software: Go to User Control Panel > Profile
Enter as much information about your CNC hardware and software as you can - it makes it easier for everyone to know what you're talking about then.
Location: Sunny Brighouse
Contact:

Post by Denford Admin » Mon 13 Feb , 2006 15:15 pm

This is a problem affecting version 1.4 QuickCAM Pro and QuickCAM 3D v3.4 - ie the current versions as of today 13th Feb 2006.
Both products had configurable post files added to let G-Code be created for any CNC machine.
The problem has appeared because the tool change section in the post file has an M05 missing.

To fix this problem until new versions are released:
Find the file Denford (Metric).ppl in
C:\Documents and Settings\All Users\Application Data\Denford\Posts
Edit the file in a text editor (eg, notepad)
Find the section [Tool Change]
and insert M5 above the line G90 M6 like this:

M5
G90 M6 T{TOOL}
M03 S{SPINDLERPM}

User avatar
Denford Admin
Site Admin
Posts: 3587
Joined: Fri 10 Feb , 2006 12:40 pm
Hardware/Software: Go to User Control Panel > Profile
Enter as much information about your CNC hardware and software as you can - it makes it easier for everyone to know what you're talking about then.
Location: Sunny Brighouse
Contact:

Post by Denford Admin » Tue 14 Feb , 2006 12:50 pm

btw you will need to turn on hidden files in order to find the post file:

in explorer goto Tools > Folder Options > View TAB - Show hidden files and folders

Post Reply