Search found 14 matches

by johnparker
Mon 20 Jan , 2020 20:11 pm
Forum: VMC 1300
Topic: 1300 Pro Z axis brake applied on rapid home or toolchange
Replies: 8
Views: 1979

Re: 1300 Pro Z axis brake applied on rapid home or toolchange

I did the adjustments per Steve's posts and added the heater on lowest setting and now can home and toolchange without issue. I'm happy the G28 goes to top of Z before homing X and Y. Thanks both
by johnparker
Sat 11 Jan , 2020 19:51 pm
Forum: VMC 1300
Topic: 1300 Pro Z axis brake applied on rapid home or toolchange
Replies: 8
Views: 1979

Re: 1300 Pro Z axis brake applied on rapid home or toolchange

Thanks, will set per your default and lower the speed next week and see what happens
by johnparker
Fri 10 Jan , 2020 18:24 pm
Forum: VMC 1300
Topic: 1300 Pro Z axis brake applied on rapid home or toolchange
Replies: 8
Views: 1979

Re: 1300 Pro Z axis brake applied on rapid home or toolchange

I am up to date with V5_68

My drives are set:
1 ON
2 ON
3 OFF
4 OFF
5 OFF
6 ON
7 OFF
8 ON
Which the datasheet tells me is 5.7 Peak, 4.1 RMS, so one setting softer than your default listing
steppersettings.png
steppersettings.png (49.18 KiB) Viewed 1757 times
stepperdrivers.jpg
stepperdrivers.jpg (105.34 KiB) Viewed 1757 times
by johnparker
Tue 07 Jan , 2020 20:13 pm
Forum: VMC 1300
Topic: 1300 Pro Z axis brake applied on rapid home or toolchange
Replies: 8
Views: 1979

Re: 1300 Pro Z axis brake applied on rapid home or toolchange

Thanks for that info Steve, just what I need I think. I have just done a full greasing on all the ballscrews, including the really tricky to get at ones! I did disconnect the Z brake, noting the axis will fall under it's own weight. I then tested the same rapid homing without any issues. I reattache...
by johnparker
Mon 30 Dec , 2019 15:33 pm
Forum: VMC 1300
Topic: 1300 Pro Z axis brake applied on rapid home or toolchange
Replies: 8
Views: 1979

1300 Pro Z axis brake applied on rapid home or toolchange

I started a thread in VR Milling, thinking I had a software problem, but further diagnosis shows a problem with my 1300 Pro Z axis brake. The symptoms are for commands G91 G28 X0 Y0 Z50 or M0 T06 the machine starts to go up in Z, but makes a really bad noise and Z stops moving without going home. Vi...
by johnparker
Mon 30 Dec , 2019 15:24 pm
Forum: VR Milling - All Versions
Topic: Use of G28 to home before toolchange
Replies: 2
Views: 1133

Re: Use of G28 to home before toolchange

Having spent some time over the holiday, I can confirm the problem is with the Z axis brake, so not a software issue. I suspect the Z brake solenoid is starved of power when the 3 axis drives all start up on rapid, and the solenoid lets go and the brake springs on. I'll start a new thread in the VMC...
by johnparker
Fri 27 Dec , 2019 13:11 pm
Forum: VR Milling - All Versions
Topic: Use of G28 to home before toolchange
Replies: 2
Views: 1133

Re: Use of G28 to home before toolchange

I'm now working on the theory that the noise I hear is due to the Z Axis brake still being on when the machine tries to home. I am experiencing this problem when I try to do a toolchange without a prior G28 too. I can see the Z Axis brake state on the Mint i/o debug screen as Output 15, so I'm going...
by johnparker
Sat 21 Dec , 2019 14:54 pm
Forum: VR Milling - All Versions
Topic: Use of G28 to home before toolchange
Replies: 2
Views: 1133

Use of G28 to home before toolchange

I'm learning to program with VR Milling V5 and driving my VMC 1300. I've got to the point where I want to make a manual toolchange during a program. I'm mostly using "G and M Programming for CNC Milling Machines" as my reference. When I complete the moves with first tool, I programmed the toolchange...
by johnparker
Sun 23 Dec , 2018 14:59 pm
Forum: VMC 1300
Topic: Removing the guard
Replies: 0
Views: 1652

Removing the guard

I'm about to service my VMC 1300, and access to the rear grease points is a challenge! Removing the guard will give me a bit more room above the spine when I lean in to the cabinet. Any tips? I'm going to source a grease gun too, any experience/tips will be appreciated. The small Hiwin nipples appea...
by johnparker
Thu 13 Dec , 2018 23:26 pm
Forum: Electronics
Topic: VMC 1300 Pro spindle won't turn
Replies: 5
Views: 1332

Re: VMC 1300 Pro spindle won't turn

It def helps to write down the thinking to work out the answer!
by johnparker
Thu 13 Dec , 2018 22:54 pm
Forum: Electronics
Topic: VMC 1300 Pro spindle won't turn
Replies: 5
Views: 1332

Re: VMC 1300 Pro spindle won't turn

Doh!
Fixed the problem. I resorted to saving a machine file, unzipping it and reading the MNT file looking for clues.
Machine cover interlock switch - I disabled it ages ago when I first got the machine, and forgot - saw the MachineSafe clue in the code.
Anyway, sorted, lesson learned
by johnparker
Wed 12 Dec , 2018 22:18 pm
Forum: Electronics
Topic: VMC 1300 Pro spindle won't turn
Replies: 5
Views: 1332

Re: VMC 1300 Pro spindle won't turn

I'm still working on my lack of spindle. Given the E-Stop error in first posts, I've been examining the E-Stop relay. 2 images, one with no power on the machine, the second with the spindle "on" via V5 Milling (but not turning). Confirming the MicroFlex led is still red when the spindle is "on" E-St...
by johnparker
Mon 10 Dec , 2018 22:03 pm
Forum: Electronics
Topic: VMC 1300 Pro spindle won't turn
Replies: 5
Views: 1332

Re: VMC 1300 Pro spindle won't turn

I thought it probably helpful to include an image when the spindle is "started". No rotation, but I heard a relay click. Indicators annotated based on a post "INPUT AND OUTPUT ALLOCATION ON A VMC1300"
start spindle.PNG
start spindle.PNG (101.41 KiB) Viewed 1324 times
by johnparker
Sun 09 Dec , 2018 19:37 pm
Forum: Electronics
Topic: VMC 1300 Pro spindle won't turn
Replies: 5
Views: 1332

VMC 1300 Pro spindle won't turn

My VMC1300 will jog fine, but no spindle action. The Microflex LED is red on power up, then flashing red/green briefly before going back red, so disabled. I checked the Debug Machine I/O page, and it shows the Estop Enable rly unchecked (see pic). I tested the Emergency Stop button, and can hear the...